Ways around latency when tracking while "top-down" mixing

Blast

New member
So this has come up for me lately. When I have tracked part of a song and have some plugins either on a group track or the master bus (this is what I understand top-down to be hence the description in the title, if I'm wrong sorry!) and then want to track some more the added plugins on the group track or stereo bus tend to cause latency on my incoming signal. Now, generally I would just save the settings and remove the plugins (usually seems to be compressors that are the problem) and then track and then bring them back to the mix. But I'm looking for quicker. easier options. I've already changed my buffer size and all that stuff. Is it possible to freeze or disable a group track? What other techniques might be useful? Thanks in advance.
 

TalismanRich

Well-known member
Freezing is the way to go. I don't know how its done in Cubase, but you should be able to Google "freeze tracks in Cubase".

The beauty is you can later unfreeze.
 

jimmys69

MOODerator
I myself am kind of a 'mix before finish tracking' guy.

There are some plugins that need to be used sparingly or shut off completely while tracking to keep latency down so that I can track a vocal or whatever instrument at the end of a project.

That being said, I have a computer that can do most of this without having to shut down everything. My main large reverb (H-Reverb) and Fabfilter Pro-L have to be disabled in order to track under 6ms without dropouts.

I do not use many VST's. Drum program stuff and drum replacement does not take much and is easily 'rendered'.

I have never actually 'froze' a track in my years. But then I don't use synths or anything that would benefit from that.


Hopefully I or other Cubase users can be of help here.

Cheers!
 
Last edited:

TalismanRich

Well-known member
I figured since the message is in the Cubase User Forum he's MOST LIKELY using a version of Cubase. It would be the wrong place to put a Reaper or ProTools question.
 

Blast

New member
I figured since the message is in the Cubase User Forum he's MOST LIKELY using a version of Cubase. It would be the wrong place to put a Reaper or ProTools

Yes, Cubase 11...sorry I forgot to mention that. Yeah sometimes I will freeze tracks but then sometimes it's just a bunch of guitar tracks that I have compressors on in a group. I haven't found a way to disable or freeze group/effects tracks. I can make due with just removing the plugins temporarily, was just looking for a shortcut I don't know about :)
 

jimmys69

MOODerator
I figured since the message is in the Cubase User Forum he's MOST LIKELY using a version of Cubase. It would be the wrong place to put a Reaper or ProTools

Yes, Cubase 11...sorry I forgot to mention that. Yeah sometimes I will freeze tracks but then sometimes it's just a bunch of guitar tracks that I have compressors on in a group. I haven't found a way to disable or freeze group/effects tracks. I can make due with just removing the plugins temporarily, was just looking for a shortcut I don't know about :)

You can't freeze group tracks or FX channels. You can however 'render in place' tracks with FX on them and open up some resources.

In other words a way to open up some computing power: Edit>Render In Place>choose appropriately. You can export it with just the channel settings (inserts) or through groups or full on through master out. You just have to select what you want. By default, the track you rendered from will be muted. Keep in mind as I have found as I do this with vocals that are done in Melodyne, you still may need to disable the insert if it is an offline plug. I may be wrong, but if the track you rendered still has an insert, It seems to still be active (meaning it taking computer resources). Shut them off on the muted track after render. Again, I really have only noticed this with Melodyne, so that may be different for a VSTi's or inserted FX, guitar sim or other.


It is basically just like exporting a track, but placing it right back into your project. You can always enable the original track you rendered/muted later. Kind of like 'freeze' for audio tracks.

And also remember, just because you hit that yellow 'bypass' button on each effect or insert, it is still running and taking resources from your PC. You have to actually shut it down with the far left power button (that also does not always work), or render to make it not suck power.

Cheers!
 
Last edited:

rob aylestone

Well-known member
I have a fairly high track count but have never had to use that feature on 11 pro. In fact my latency never changes when the processor works harder. Delay indicates time being spent doing something, so first call should be the meter to see how hard it’s working. When I’ve done something stupid and put in repeated instances of a heavy effect, processor load goes into the red and it glitches. It does NOT on my systems increase latency. This suggests cascaded small delays, and Cubase allows you to shift things in time in the inspector, so if this is what you’ve done, you should be able to compensate. Freezing tracks wont really help, will it? Your problem is most likely real delay in the plugins, not latency. Maybe advancing the source of the cascade till the output aligns is something to try.
 

Vigo

New member
Hey. I personally would just hit the delay compensation button on the top left, lower my buffer size, track, then readjust when i've tracked what I need. The button does it all for you.
 
Top