No sound midi out

Roland007

New member
Hello, I am a newbie here :)

I play a digital piano and like to do some recording in Reaper, but run into a setup problem. The midi output gives no sound :( I tried and checked everything I can think of with no success but I don’t know too much about recording tech…

Here’s what I have running: My piano is connected to a usb soundcard/ audio interface (an old one M audio audiophile usb) with midi in to midi out and midi out to midi in. The audiophile is connected to my windows10 pc through usb. A driver is installed but it is not updated for win10/ not available. speakers are connected to the audiophile line out - audio played on the pc does sound on these speakers. Another set of speakers is connected directly to the piano. The piano also has audio cables connected to audiophile.

When I run reaper midi in does work, I can record midi and it shows. However I can not hear it back; no sound when I play the midi recording and no output visible. I/o set to audiophile midi out. Loaded audio recordings do sound in Reaper, only not the midi. Asio also shows the audiophile in settings. Same thing in for instance synthesia: midi in is fine, midi out gives no sound.

Am I missing something here? Any help is much appreciated as I am getting frustrated after hours of trying to solve this… thx :)
 
Last edited:

LazerBeakShiek

AKA Optimus Prime LEGO Vampire
Usb is connected for midi. What VST for sound? Make new virtual instrument track with the recognized midi controller in reaper.

As just midi, no sound is going through.
 

Roland007

New member
Usb is connected for midi. What VST for sound? Make new virtual instrument track with the recognized midi controller in reaper.

As just midi, no sound is going through.
It should send the midi back to my piano and sound the internal tone/instrument selected on my digital piano…
 

spantini

COO of me, inc.
On the midi track you recorded, open the FX window and add ReaSynth, then play the track to see if it sounds.
 

Roland007

New member
The hardware piano's sound stops when a midi cable is inserted?
No, it still sounds on the speakers that are directly connected when I play and it does also record through midi in when i play. Only thing is that I get no sound when playing back the midi track with i/o set to midi out eventhough the piano is turned on
 

spantini

COO of me, inc.
In my piano’s settings or reaper settings? The same problem of no sound from midi out occurs in other programs as well (synthesia)
In Reaper's settings - so Reaper knows which device to send midi to for playback.

This may or may not apply. After selecting Input:MIDI for your track, see if your piano shows up in the mext menu. Mine is SE25 (but I have "all midi inputs" selected here for my drum kit). If your piano shows up there, select it and then all channels from the next menu.

If your piano doesn't show up there, it's something else.

midi.jpg
 

gecko zzed

Grumpy Mod
A few things to check

1 Make sure that in preferences, the audiophile is selected as a midi output device.

2 On the track control panel, check the routing and look for midi hardware output, click the down arrow to select the audiophile

That is how you send the midi back to the keyboard.

If you play a midi track you should hear your it via your keyboard's speakers.

If you have the keyboard's audio output connected to the audiophile, you should be able to hear ti through whatever speakers or phones you have connected there.
 

rob aylestone

Well-known member
If it’s connected via midi, rather than usb, it wont show up as anything other than an active midi source. Reaper doesn’t know what the source is, just that there is one arriving! If it records coming in on midi channel 1, but the piano wont receive midi, it’s no loss. The gesture will be disabled in a piano menu, or maybe set to a different channel. Sending on the same channel as receiving creates double notes, so there is often a feature to disable it, or make it revieve on say, ch 2 to stop the echo. Once you make the piano respond, you will then get a double note because reaper will send it back out. There hopefully will be a way to switch it off in reaper. I don’t know. Cubase has this. If the piano sound from reaper is good, I’d just turn the piano down on its volume control and use reaper’s piano.
 

spantini

COO of me, inc.
Boy, am I glad you guys came along. I was about to launch into my "disected orange" solution. That's where you.. Uh.. never mind...;)
 

Roland007

New member
Update:
Hello, everything works now. I am unsure what the problem was, but after turning all devices off (pc, piano, m-audiophile), rebooting and reinstalling and setting the m-audio drivers it works. I think there was s problem with the asio, but can’t say for sure.
Anyway, thanks alot to y’all for thinking along!
 
Top