Clicks? Pops? Skips? Fix your DPC Latency NOW!!!

shackrock

New member
As I've had years of problems with laptops (and occationally desktops) that have large DPC latency spikes, I've finally found the solution!!!!

First, check to see that DPC latency is indeed your problem:
http://www.thesycon.de/deu/latency_check.shtml

Anything in the red, and even yellow, will often cause problems.


The only cure that I've found has been thanks to this thread: http://www.native-instruments.com/forum/showthread.php?p=532045&posted=1#post532045

There, you can read through and find out a fix that nearly always works for people:

1. Download Process Explorer here: http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx
* Go to your "system" entry, and double click it (or right click -> properties).
* Go to the Threads Tab
* Find ACPI.sys
* Click Suspend.

Now, check your DPC spikes again, and $10 says that they are gone!!!

Do you're reording, and when you're finished, open processes explorer up again. Go to System -> Threads, and Renenable the ACPI.sys.

You will need to re-enable before shutting down, or your system will just kind of hang after the windows shutdown process (and you'll have to hold down your power button).


Hope this helps people, it saved me - and worked on all the laptops that I was earlier having problems with.
 

BushmasterM4

New member
ACPI deals with "Power Management" and can be a resource hog. Some pc's are fine diabling it. But some will not boot (especially store bought systems loaded with prebundled software and or flakey bios's). So if you do try this, be aware it may cause problems. If one is familiar with the "bios setting in your pc", then if you go to the "power management" section of the bios you can disable ACPI there and see how your system will perform. Then follow the post above too. Its best to disable it all together "if possible" and leave it disabled in both the BIOS and in Windows. But LIKE I SAID, some pc's will not function properly with out it running. Also network adapters cause spikes and noise. Disable you network adapters too. Find your network adapter, right click, and choose disable. If you need to get online you just have to enable it.
 

ido1957

9K Gold Member
I disable my Internet WIFI (switch) otherwise I get lots of skips and pops when recording...
 

shackrock

New member
To clarify based on the above responses:

1. I do NOT mean to DISABLE , only SUSPEND the process. I agree, disabling the process really causes a lot of things to not work right - including many important things! This is also why I DO NOT reccommend disabling this in BIOS, either.
2. There ARE many other methods that MIGHT work on CERTAIN laptops. However, after you've exhausted other methods (namely going through device manager and disabling items until the spikes stop / wifi switches), THEN you should try/use this one.

Hope this helps!
 

calrec

New member
Discrete sound card better thqan on-board?

ACPI deals with "Power Management" and can be a resource hog. Some pc's are fine diabling it. But some will not boot (especially store bought systems loaded with prebundled software and or flakey bios's). So if you do try this, be aware it may cause problems. If one is familiar with the "bios setting in your pc", then if you go to the "power management" section of the bios you can disable ACPI there and see how your system will perform. Then follow the post above too. Its best to disable it all together "if possible" and leave it disabled in both the BIOS and in Windows. But LIKE I SAID, some pc's will not function properly with out it running. Also network adapters cause spikes and noise. Disable you network adapters too. Find your network adapter, right click, and choose disable. If you need to get online you just have to enable it.

This is my first experience with on-board aound. Asus M4A78 Pro Mobo with VIA HD Audio Deck. The Mobo doesn't like ACPI disabled :mad: Shopping for a decent sound card.
 

esotericxa

New member
Windows 7 Go into power, change the minimum CPU power to 100%. Also works at 90% for me. Do it while running DPC latency tool to see effect.
 
Top