Using an old Drum machine (Alessis SR-16) as a midi-sequencer driven drum module

Are there any kind of MIDI settings in your interface? Is it possible the problem is the middle man?
I tried it with Cubase and it worked, I nearly fell off my chair. But, I haven't used Cubase before and found it a strange and alien place and I didn't like the sequencer much. I'm sure it's fine, and I guess I could convert, but, I've invested quite a lot of time in Kenny Gioia's Reaper video's. Could I do that again for Cubase? I still really wanted it to work in Reaper and at least now I knew what settings would work on the SR16 for sure (Midi Ch omni, at least for now, Drum in on V1, Drum out off, Note's on the defaults, Clock in and out off, midi thru off, PRG Change On and Note Map Normal). I also knew now that the Interface and my cables work and that everything is patched correctly. So, I closed Cubase and tried Reaper again. Nothing, for about an hour, trying many of the things I had before. Really fed up. But then, I'm really not sure exactly which thing it is that I did that made the difference but now, at last, it works too. The whole setup is: Midi out enabled to my interface which has a midi cable going from it's midi out to the SR16's midi in. SR16 settings as above. Audio outs from the SR16, up to four, plugged to the interface. Add a track to Reaper and then add Reapers Sequencer "Megababy" using the FX button. Program in some beats. Using the tracks "Route" button then under Midi Hardware Output choose your interface's Midi Out (this may have been the step I was missing, but, I think I had done this before). I think I had this all in place and was still getting nothing and then chose, in the sequencers "edit" dialogue, the option to Full Recompile/Reset. I think it started working then - I'm not sure because it took me some seconds, 10 or 15 maybe to realise it was working and I'd maybe clicked a few other things by then. So in the end I'm really not sure what the thing that did it was. thanks to everyone that posted their help, in particular @rob aylestone and @vox for helping me to understand what was going on, and @spantini , for general encouragement and good humour. Mission Accomplished.
Finding out something does work is always a weight off your mind isn't it!

I've been using Cubase since 1994, and over the years I've noticed a lot of people just find it hard work - just like Photoshop. One of the snags with Cubase, and it applies to Logic too, is that it does so much in such a wide variety of areas that the menus are full of stuff I have never ever used - and some have been there for 25 years, so some people must be using them for them to remain. Cubase was also streets ahead in MIDI data manipulation way before they started recording actual audio. I think they now yell loudly that you don't have to be a conventionally trained musician to use it, and maybe this is true, but you do need to understand some music theory and things like tempos, time signatures and things like triplets - because their quantise and display settings need you to understand how these work. I still have to Google some things when I need to use a feature for the first time. Cubase isn't that obvious, until you find what you were looking for and it makes sense. Pro-tools always used to be known for being great for audio recording, but it's original MIDI implementation was terrible. Cubase even had a version called 'Score' - you really had to be dedicated to use it to enter sheet music, so Sibelius popped up and people used that - but Sibelius was dreadful with MIDI. By the time Reaper popped up, the developers had a pretty good handle on what the 'average' user wanted from a DAW - I still refer to Cubase as a sequencer, because DAW is a relatively new term, and audio was not in Cubase's vocabulary for a long time. On Youtube, we have Guy Michelmore's excellent music videos and he uses Cubase, and I'm forever rewinding to see some feature I didn't even know existed! Now you have reaper behaving - you'll be fine. Glad you got it sorted.