SOLVED: Yamaha TX802: "Trap Error!" (WTF is it and how do I fix it?)

Blue Jinn

Rider of the ARPocalypse
TX802. plays fine through MIDI. However, once you record a sequence and stop recording, it gives "Trap Error!" and won't respond. Requiring a power cycle. This is with two different MIDI interfaces

Win 10, Behringer Uphoria, latest Cakewalk by Bandlab -or-
WinXP, Delta 2496, Cakewalk 9

MIDI chain is Kurzweil paino > interface > TX802 > Kawai K4r > Kawai XD-5 > Digitech MIDI Vocalist > Kurzweil piano

However, I've tried with just the keyboard > interface > TX802 with nothing else in the MIDI chain.

With just a MIDI keyboard connected (M-Audio Keystation 61), it is impossible to play, immediately goes to "Trap Error!" if after powering up.

Can't find anything about this on the 'net
Last edited:
Your midi chain looks like a strange loop.
Pull that last connector that round trips to the KW Piano and see what happens. Looks like you've got a feedback loop race condition going.
When you play back your sequence, you don't wanna play back your KW piano. You simply wanna play back your modules. What interface we got here? 2X2? 4X4?
Thanks. I tried that. Also, eliminated everything but the TX802 so Kurzweil > Behringer Uphoria > TX802 same issue. Also, with a M-Audio Keystation directly connected to the TX802. "Trap Error!"
Repair shop.
I'm running two TX802s and have never had a lick of problems. The caps are old and they say the Yamaha rams go out.
I saw that, thanks. Also got a response on the DX-7II/TX802 FB group explaining a trap error from a computer software perspective. I'm going to hook back the Delta 2496/ WinXP box and see if I get the consistent trap error from the DAW transport stopping. I said above, but now I can't recall if the error was occurring with the Delta consistently or not.
Well.....okay..... that's really good.
Still sounds like a repair shop deal, though. I'm not seeing the User-Fix that we'd like to see happen.
Yeah. I'm going to pick up my ARP from the shop sometime this week, and I'll ask the dude there about it. I did buy the latest firmware ROM from a guy on Ebay, current version is 1.1 latest is 1.5. That should come in about a week or so. (Hopefully, thanks Vlad....)
Upgraded firmware to 1.5. No more Trap Error!
(Still having trouble with DX-Manager, but that's a different issue now)