Fostex B-16 Wont Record!


New member
NEED HELP! Just got a Fostex B-16. Everything seems to work except I cannot get it to record anything and I feel like i have tried everything! Am I missing something? I get the input connected and and getting a signal on the mixer AND the reel to reel, but nothing stays on the tape when I press record! WHAT AM I MISSING?!?!?!?!

-thanks guys
Did you clean the heads? I get units in all the time not particularly Fostex but then the problems are the same- either dirty heads or bias oscillator is out. Does it erase is the fisr question. If no erase then that is sign that the bias oscillator is not working which is where bias for recording comes from as it is tapped off of that. IF it is erasing then you could have a audio section problem but not on 16 channels as that many will never fail at once. Proper analysis is needed to know what to do next. It is like the shops I worked at and a guy would come in and say "it don't work". These are not the kind of thing a Technician wants to hear but we fixed them anyway.