CD Architect will not burn my red book master!


New member

I am/was almost there. Mixed, mastered 17 tracks, named all tracks, typed in ISRC codes, triple-checked everything, inserted a blank disc, pressed BURN CD and . . . . scanning for CD drives . . . none found. :mad:

Tried on two different PCs - same result. CD Architect simply will not burn my Red Book master!

What am I doing wrong? Help!
Which version of CD Architect?

Not finding a CD drive points more to a hardware config issue I'm thinking, but you tried on 2 different PC's... This wouldn't happen to be an external CD drive would it?

What else can you tell us about the PC's? (OS, RAM, etc.)
Thanks for your reply. It's pre-Sony Sonic Foundry CD Architect 5.0 and the OS on my studio PC is Vista while this one is Windows 7. Neither was an external CD drive.

I installed it a few months ago in PC 1 (Vista) and only today in PC 2 (Windows 7).

The choice of drives (drop-down) says only "None". I'm perplexed.
I'm seriously fuming with Sony and I have a right to be.

1. My CD Architect (bought legitimately from an authorised dealer) cannot or will not recognise a CD writer when I click on Burn CD. I installed it on a second PC with the same result.

2. I then uninstalled it from my studio PC and attempted to reinstall it. My serial-number was rejected. Three times. This is the original serial number printed on page one of the 110-page official manual which came with the original package when I shelled out hard-earned money for the software.

3. I decided that I would buy an upgrade to CD Architect 5.2 @ £29.00. Without an upgrade it costs £105.00. My official CD Architect serial number was rejected with the message "This serial number does not qualify for an upgrade". Why? I bought the software legitimately - there is NO reason why it "does not qualify for an upgrade".

4. I posted a question on the Sony 'support' page 25 hours 17 minutes ago and it has not yet been answered. Is there some good reason why Sony treats this customer as a pariah? I do NOT want any "self-help" options. I want a solution from a Sony employee whose wages are being paid by fools like me who once trusted the brand. Never again.
I find CD Architect to be the single biggest waste of ones and zeros on my entire hard drive...and yes, I'm including the obligatory Windows Solitaire game in the list. I have version 5.2, along with Sound Forge Pro 10, and although it recognizes my CD drive, it's slower than a politician to do anything with it. For example, I add three WAV files to the media pool (averaging 4.5 minutes each), and set to burn a CD so I can check the latest mixes in the car. It burns the lead-in, and then sits "dead cycling", speed listed at 0.0, and time remaining at about 442 minutes. To burn three songs to a disc. Seriously, Sony? You call this the industry standard? I call this garbage....pretty pathetic to pay for this, and then have to resort to the Roxio application that came with the computer to actually CREATE a CD...and yes, the computer more than meets the hardware criteria....i5 processor, 64 bit OS (Win 7), 8 gigs RAM, 500 GB drive, etc., so I don't see hardware as the issue here.
External Burner!!

Hello, I had the same problems as you and, in my desperation, I tried using an old and dusty usb external burner.
Believe it or not the CD Architect recognize the usb drive!!
No excuses for Sony. Just to maybe help you.

Hug. :listeningmusic:
I'm not familiar with CD Architect. Does it give you the option to write an ISO or other "disc image" type file to your hard drive? Can you use that and then something like maybe MagicDisc? Not the best option, I know...