bandlab Sonar dropouts/glitches


I'm a long-time sonar user, and when I had to move up to Windows 10 I couldn't reinstall my previous version, maybe because it was sold to bandlab. I had to install the bandlab version and lost a whole lot of plugins. It's just a ghost of the setup I had before. Now I keep getting brief dropouts and I can't trace down the cause. It's much better if I disable the plugins so that may be the problem but I can't narrow it down to which plug-in is the cause. Has anyone else noticed the band lab version being more glitchy or having dropouts? It could also be the limits of my computer.
I think about changing DAW's but I have so much time invested in sonar. I looked at an introduction to Reaper and also Ableton and they make my head spin with complexity. I know Ableton is supposed to be one of the best but I don't think I have the heart to start over again. Thanks for any insights!
As I am currently experiencing what might be called dropouts or glitches using AmpliTube 5 with Reaper, I can say that increasing the buffer block size in my interface and in Reaper's preferences settings to match eliminated much of that - though it still rears its ugly head if I push AmpliTube 5 the least little bit further. Switching back to AmpliTube 4 for some of the tracks eliminated this altogether.

Now, that's all fine if your block size is too small, but it could always be a different problem from mine.

Just a nudge toward Reaper - once you do all your settings and routing to set it up, it can be as simple to use as a 50's Radio Shack tape recorder.. or as complicated as you fear if you go too deep to soon. Kenny Gioia's videos make it easy.

Reaper 1967

reaper 1967.jpg
Last edited:
Changing to Win 10 might have also introduced some other issues. Check the Latency Monitor to see if there is a problem with things like WiFi or NDIS. A fault that causes the computer to wait for a long time before it moves on is just the type of thing that makes for hiccups.

Resplendence LatencyMonitor
update FYI: I just remembered I used to run an MME driver years ago. Then I got a new ASIO interface & I think that's when the glitches began. i just switched back to MME & the problem resolved. I have no idea why since ASIO is supposed to be better? I'm doing audio only, no midi, so it should work OK.
I'm really surprised that you are getting better performance from MME. What are your computer specs? What interface are you using? Are you doing overdubs?

My interface is a Tascam 16x08 and I found that latency was terrible when I tried to use MME. I also tried ASIO4ALL and it didn't really do a great job. I'm running the Tascam driver without issue. The critical issue was setting the buffer correctly. I don't run plugins like Amplitude, so it doesn't stress the system during recording anyway.

If there is a reason for going with a faster computer, it would be to make it easier for the system to handle tasks like plugins that are cpu intensive.
I use a dell Inspiron laptop, 17 5000 series...not sure of the spex. The interface is a Focusrite Scarlett 1808. Overdubs but no midi with the audio. Maybe it's not better in other respects, but it fixed that problem. It wasn't dropouts but some intermittent noise that's hard to describe.
Check under Settings: System: About and it should tell you the processor and memory. The Dell 17-5000 series can have anything from a Pentium 4405U series processor to a 7th gen I7-7500. BIG difference in performance, like comparing a Corolla to a Corvette. I'm not saying you need to change things. If it's working for you, fine. It's just that you might be able to get more out of what you have.
Thanks. How do i get more out of what I have?

Device name DESKTOP-S3PL28G
Processor AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 2.00 GHz
Installed RAM 16.0 GB (15.6 GB usable)
Device ID 36E59E15-11FE-4F60-B894-9376A767BB39
Product ID 00325-96348-95813-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
The Ryzen 5 should be plenty strong enough. It's similar to my I5-4570 in processing speed. DId you pull down the Latency Monitor that I referred to in a previous post? That will tell if there is some special issue.

It will give you a report that looks like this:

When you used the ASIO driver, did you use Focusrite's driver and mix control, or ASIO4ALL? Buffers probably need to be around 128 to start. MME has been around since Windows 3.1! I don't think I've even seen it on my newer systems. Microsoft has WASPI and Directsound as current sound drivers.
I use Focusrite's driver & mix control. I didn't check the latency monitor yet since it seems to be OK now. I'll bookmark the site in caseI have further problems. I'm not sure latency was the issue, it was more like an intermittent static, hard to describe. Thanks for all yr input!
Parish , Your old Sonar (64 bit) programs should still be able to be installed on win 10. If they are installed "before" Cakewalk by Bandlab , All of your vst's instruments etc. will still be available in the new Bandlab version . It will even open up any old projects done in Sonar. The old Cakewalk command center is still running for re-downloading your old programs (if you ever set up an account with them and can still log in). Sonar "Platinum" users have Everything from their old program running in CbB. Cakewalk Discuss is the official forum for the new CbB ... mark
Thanks Mark! I'll look into it. It's been a few years now so it may be too late as I may have deleted some things to save space. I wasn't on Platinum before - just Producer so I don't know if that matters.
This may be way off base, but your mention of intermittent static made me think of something you can get with plugins trying to use gear that's not available - e.g., my AmpliTube 5 VST has pre-assembled chains of amps and cabs. Even though I select an amp I own, it's initial chain contains a cab I don't own (which doesn't operate, but the amp does) and this introduces a hissing sound at random points in time as long as I leave it that way. If I replace the unowned cab with one I own the hissing stops.

It's a longshot.. just covering the bases.
Update if anyone is still interested: The MME driver setting did fix or mask the problem, but recording is no good with that. So you're right ASIOis best, especially for recording. I think I've traced that noise down to a couple of compressors. The breathing noise was hard to describe, not static nor dropouts but I think the compressors were overworking if that makes sense, so I can fix that. Thanks for your input
Compressor pumping can really sound bad. My fix would be to cut back the compression ratio, adjust the attack time, and adjust makeup gain.
Great, thank you! I'll try those settings. I didn't know where to start except to disable the compressor entirely.
Bit OT but with regard to 'upgrading to W10' ? I did that a while ago when the freebie was about, put it on a W7 desktop...HATED it and quickly rolled back to 7 only to find many of the functions of my M-A 2496 sound card had been lost and I never did get them back.

I did not upgrade a W7 i3 HP laptop but waited about 18 months for W10 **** to die down then bought a refurbed i7 laptop (SSD 8g RAM W10) Thinking the W7 machine would eventually be rendered useless on the web. Never happened and I use it online several times a week.
Bottom line: I shall leave W11 alone for at LEAST a year and then look for a W11 second hand laptop.