Loop track without a lag

I'm not sure if this is the right place to ask, but let's see.
I created a 3 min song to make 3 hours video. The track will be looped. When I play it in DAW, everything was perfect. There was no lag while looping. However, since I drag it into Vegas Pro, it made a lag on the repeat spot. The noise(Tick sound) is obvious.
Thus, I've been trying many things.
1) Changed the high pitch melody part of the beginning and the ending part.
2) Added fade-in and out at the beginning and the ending part.
3) Changed the order of each bar.
4) and etc

But none of them worked. The only way is that using overlap in Vegas Pro, but it takes too much time for 3 hour long video. As I'm gonna make it every single day, I'd like to make the task as simple as possible.
Any ideas?
 
Last edited:

spantini

COO of me, inc.
A little experiment : In your DAW, try extending the loop another 3 min (2 identical loops) and then gluing them together into a single item. See if that has a lag in the middle after moving to Vegas Pro.
 
A little experiment : In your DAW, try extending the loop another 3 min (2 identical loops) and then gluing them together into a single item. See if that has a lag in the middle after moving to Vegas Pro.
Hi, spantini. Thx, but I don't understand your point. How can it be different? It just makes the song longer. Isn't it?
 
Last edited:

Ujn Hunter

Active member
If looping it in the DAW has no issues, why not just render the entire 3hr track from the DAW and insert that into your Video, then you won't have to worry about the "in between" or "editing" in the Video editor?
 
Top