Inserting empty space at the beginning of the project

mjbphotos

What?!?
Easy, right? Make a time area selection for the length needed, click on the insert place, select 'Insert empty space at time selection' from either the 'Insert' menu, or by right clicking.

Except that the ''Insert empty space at time selection'' is grayed out and not available to me! Didn't find anything in the Cockos forum about this problem.
 

mjbphotos

What?!?
No help here, but I am curious what you do with that empty space.. it's purpose.

I have a 4 bar count-in before the music starts (already recorded multiple tracks). I now want to add 8 more bars to the intro of the song. 'Insert empty space' moves all tracks AND markers and tempo changes to the right by that amount. Otherwise its a tedious process to move everything. I also want to be able to insert another 8 bars into the lead guitar section later, but that becomes a real nightmare without this feature.

I updated Reaper (to V 6.68), restarted Reaper, still doesn't do it. After making a time selection, if I right click and select 'Set selection to items'. the ''Insert empty space' is now usable, but doesn't actually insert any empty space.
 

markmann

Active member
I know this subject has come up in the Reaper forum before. Not sure if this is the same as you tried:

This is one about converting markers to regions:

Hope these help. Good luck.
 

mjbphotos

What?!?
I know this subject has come up in the Reaper forum before. Not sure if this is the same as you tried:

This is one about converting markers to regions:

Hope these help. Good luck.
Interestingly enough, I can't create a 'region' from a 'time selection' either. Got to be something un/deselected somewhere in the menus!
 

mjbphotos

What?!?
Are you left clicking to create your time selection and not just clicking on the ruler?
Left click, hold, move to create a time selection.

I gave up, and manually moved everything. PITA - first select all the tracks, then 'select all' to make sure I get all the 'pieces' on each track, before moving them all. Then I split all the tracks and manually moved them to create the extra space in the lead guitar section. Then move all the markers. Luckily this time I had no tempo changes in the project, that gets real wacky as the 'grid' lines all change appearance when you move tempos.
 

jamesperrett

Active member
One alternative would be to switch ripple editing for all tracks on and then just move the first item wherever you want it to go. Everything (including markers and regions) after the first item will move to the correct position relative to the first item.
 

bouldersoundguy

Well-known member
Weird. I was able to select time at the beginning and insert empty space. I even put some markers and a tempo change in, and it all moved accordingly.
 

spantini

COO of me, inc.
It is to allow you time to clamber over the cables, move your reading glasses to your forehead, adjust your earphones, and pick up your drum sticks.
That's what I insert space for, but I don't do anything with markers or tempos. Since I have to set my mic up about 6-feet to the side of my PC when I track my vocal(s), I need a couple measures of dead space to dodge back to the mic and compose myself.
 
Last edited:

mjbphotos

What?!?
I always have empty space/measures of click track ahead of the start point, I needed more this time!

I know I have been able to 'insert empty space' before - with an older version of Reaper and probably running Win 7, too. Bugs me that I can't seem to do it now.
 

spantini

COO of me, inc.
I see changing the Project Start Measure to a negative number adds that value's empty space to the beginning, but in Kenny's example a value of -1 adds the space, yet the song still begins playing at Bar 1 - which leaves me wondering why insert that space if it doesn't begin playing from the negative location's start of -1 ..? His example is confusing me. I think he may have left out how to set it up to begin at -1. So there may yet be a solution in there somewhere.
 

gecko zzed

Grumpy Mod
I tried to replicate the problem but have been unable to. I had thought you might have inadvertnatly clicked the locking icon (little padlock on the menu bar) but that doesn't prevent you from inserting empty space. So I am lost for an answer.
 

Ujn Hunter

Active member
Sorry you couldn't figure this out... there must be some setting in Reaper or Project Settings that is "overriding" the ability to do this for some reason... hopefully someone can figure out what is causing it. It's definitely not the "version of Reaper" you're using or anything...
 
Top