Alesis Multimix 16 Firewire driver install on macOS High Sierra, Mojave, Catalina


New member
I've got an older Alesis MultiMix 16 Firewire mixer that I'd LOVE to use with a newer MacBook Pro (2017 High Sierra, might upgrade to Mojave). This is a rather old unit (2007ish?), but acts as a great 16 channel analog mixer + 18 channel audio interface (16 individual POST FADER/EQ channels + a stereo main mix!). Not too surprisingly, the outdated drivers don't seem to want to work with the newer macOS operating systems (more on that later...). That being said, there are plenty of Firewire MultiMix owners who have successfully installed the older drivers and gotten them working with their newer macOS (and Windows) computers. Most of these users had posted files and walkthroughs to achieving this on another forum called "" or something like that, but those forums were recently retired, and all that information is lost :(

From what I've gathered, the latest Multimix Firewire drivers you can find online work fine, it's just that the newer macOS operating systems have an advanced security protocol (SIP) that blocks the driver installation process from installing where it needs to be (/System/Library/Extensions). To get around this, you can boot into recovery mode (command+R on restart) and disable SIP via Terminal with the command 'csrutil disable', and install the driver (AlesisFirewire.kext) using Kext Utility app. I've tried variations on this multiple times but haven't been successful yet, and it's sooo frustrating. There was mention of possibly needing to update the firmware on the mixer, but that info is gone and I don't know how to check the firmware version of my MultiMix, nor where or how to get the correct firmware update installed.

This is the latest and most up to date forum post I could find on the subject, and documents macOS Catalina users being able to use these older MultiMix Firewire series mixers. There are also links to most recent drivers and the Kext Utility:

**unable to post links cause I'm new**

Hoping there are other users on here familiar with this and can help me out, or at the very least this info will help others


I had some problems with an old Tascam firewire mixer working on High Sierra and Mojave. I found that after re-installing the drivers I had to go to Security & Privacy in the System Preferences and manually accept/allow the drivers to install. It recognized the mixer just fine after that, although I still have some intermittent problems with Mojave seeing the mixer.


New member
Thanks for your reply. I'm familiar with having to do this for some installations, but was never given that option for this. Will try again though, see if that pops up.

Ugh, still not allowed to post links :(