I recently scored a 2488 on ebay for $60.00. It was listed as an "as is/ for parts or repair". The seller stated that he bought this from someone and he didn't know how to use it. He said it would boot up (screen would light up) but that was all it would do. I figured worst comes to worse, I can part it out if I can't get it to work. The hard drive, display and cd-r would get me my $60.00 back. Anyway, received the 2488 and booted it up. Adjusted the contrast control and the home display came up. All the select/track/record buttons work..........transport controls seem to work. But when you press the play or play/record butons they flash as if it's in mtc slave mode waiting for a chase signal from a master. I tried to stop the process and press stop. Everything appears to cease like it's suppose to but when I press menu to check and see if it's in MTC, I got an error message that says "can't do this, you must stop transport first" Clearly the HD is stopped so what gives? I've tried the hard reset sequence, I've replaced the HD with a new one, tried to run an update for the OS (could only download the v 1.02 from Tascam)...this thing shows that it's already running v.1.03. Anyone have any suggestions of something else to try aside from sending it to Tascam's Service center (the horror). As I said, I"ve only got $60.00 invested but I'd really like to get it working. (Considering what this technology cost just a few years ago) There's a working one on EvilBay right now , bidding is at $81.00. (My wife will kill me) I kind of like 24 tracks in a standalone that I can slave another unit to and have more tracks if necessary. Tascam products have served me well over the past 20+ years. I'm open to any suggestions