So I have a Windows Xp system with Protools LE7 and the Waves 4.0 plugins are causing issues. The system will crash when opening a session with waves plugins. It will say, "Protools has encountered a problem and needs to close..." The error message is a waves 4.0 reference. When the plugins are uninstalled the system will start without the plugins of course. I can open new sessions but cannot open any old sessions with the plugins.

Is there a way to fix this? I'm looking to upgrade to the latest version but i'll need a new system and a new interface as the Digi 002 rack is obsolete.

Any recommendations are appreciated.

Thanks.