Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: Focusrite Scarlett 18i8/18i20 or PreSonus Studio 1810 with Reaper?

  1. #1
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867

    Focusrite Scarlett 18i8/18i20 or PreSonus Studio 1810 with Reaper?

    Sign in to disable this ad
    Hi all! I hope everybody's well.

    I'm replacing my good old Tascam US1641 which I was very happy with, but is not supported anymore. Right now I'm using Focusrite Scarlett Solo 3rd gen. as a temporary setup, on my iMac OS X Catalina, running Reaper.

    I narrowed down my search to these two-three: PreSonus Studio 1810, or Focusrite Scarlett 18i8 (2nd Gen), or Focusrite Scarlett 18i20 (2nd Gen). My main choice for these is that they promise "plug-and-play", no drivers to install (and upgrade).

    My first choice out of all of them would be PreSonus Studio 1810 because it has enough outs for monitoring (I need at least two sets of outs: one for the monitors, and another for the PA system through the mixer) as opposed to Focusrite Scarlett 18i8, which has only one pair of outs. 18i20 also has enough outs but it's more expensive, although I may find some good deal on ebay.

    My questions is how they perform with Reaper on a system similar to mine? I'm quite used to working with Reaper and don't really want to install and learn something new (which come with those interfaces). Does anybody of you have any of those mentioned above interfaces and can share your experience? Please share and help. Thank you!

  2. #2
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867
    I guess I got impatient and just went ahead and ordered PreSonus Studio 1810 from Amazon. Can't wait to get it. I hope it'll work with my setup. If anybody has to say anything VERY NEGATIVE about it, there is still time for me to cancel the order, or return it without opening the package.
    I hope not ...

  3. #3
    Join Date
    Oct 2005
    Location
    Ranelagh Tasmania
    Age
    69
    Posts
    8,435
    Thanks
    238
    Thanked 731 Times in 605 Posts
    Rep Power
    21474859
    I've been using Presonus with Reaper since about 2010. I am happy with that combination.

  4. The Following User Says Thank You to gecko zzed For This Useful Post:


  5. #4
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867
    Thank you, gecko zzed, it's encouraging!

  6. #5
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867
    Today I got my new Studio 1810, hooked it up and tried to record four tracks at once: 1 - mic guitar amp, 2 - mic for voice/ trumpet, 3 - line bass amp, 5/6 - drum machine. It recorded well. But playback is glitchy. When I stop and play the part where there was a glitch, it played well, but then it plays glitchy in another spot. That way I know that recording is fine but when it plays back then there is problem.

    Probably I should do dome adjustments in preferences. Can anybody help me with this problem? My system is: mac OS X Catalina, Reaper, Presonus Studio 1820, Universal Control. Recorded in 44,1khz.

    Thank you!!!

  7. #6
    Join Date
    Oct 2005
    Location
    Ranelagh Tasmania
    Age
    69
    Posts
    8,435
    Thanks
    238
    Thanked 731 Times in 605 Posts
    Rep Power
    21474859
    That may be an indication of slow or interrupted reading data off the drive, or some other process hijacking the CPU.

    Do you experience the glitches when playing other media (e.g. videos from youtube or whatever)?

  8. #7
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867
    Quote Originally Posted by gecko zzed View Post
    That may be an indication of slow or interrupted reading data off the drive, or some other process hijacking the CPU.

    Do you experience the glitches when playing other media (e.g. videos from youtube or whatever)?
    YouTube playback is fine. Also this same system worked very well with tascam us1640 and Scarlett Solo.

  9. #8
    Join Date
    Oct 2005
    Location
    Ranelagh Tasmania
    Age
    69
    Posts
    8,435
    Thanks
    238
    Thanked 731 Times in 605 Posts
    Rep Power
    21474859
    Does it glitch on playback with just one track going and the others muted?

  10. The Following User Says Thank You to gecko zzed For This Useful Post:


  11. #9
    Join Date
    May 2010
    Location
    Chicago
    Posts
    91
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Rep Power
    14867
    Quote Originally Posted by gecko zzed View Post
    Does it glitch on playback with just one track going and the others muted?
    That I haven't tried. I'll try it tomorrow and let you know. Thank you for your help!

  12. #10
    Join Date
    Apr 2005
    Location
    Lowell Street Studio, New England
    Posts
    12,406
    Thanks
    19
    Thanked 604 Times in 574 Posts
    Rep Power
    18632361
    Make sure you have other processes shut down - wireless internet, etc.
    Mike B My new album on CD Baby: Fact and Fiction
    My Bandcamp site: http://mikebirchmusic.bandcamp.com

  13. The Following User Says Thank You to mjbphotos For This Useful Post:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Reaper and Focusrite Scarlett 18i20 gain problem
    By ChicagoJames in forum Newbies
    Replies: 7
    Last Post: 04-04-2019, 17:01
  2. Focusrite Scarlett 18i8 Headphone help?
    By jconradi in forum Newbies
    Replies: 1
    Last Post: 12-28-2016, 00:59
  3. Too much dynamics or insufficent preamp? (Focusrite Scarlett 18i8)
    By SkyFly in forum Digital Recording & Computers
    Replies: 18
    Last Post: 10-12-2014, 02:11
  4. Focusrite 18i20 and 18i8 issue
    By Dmac252 in forum Digital Recording & Computers
    Replies: 3
    Last Post: 05-15-2014, 07:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •