Page 1 of 6 1 2 3 ... LastLast
Results 1 to 10 of 52

Thread: Emu 1820m Dock Repair..?

  1. #1
    Join Date
    Jul 2005
    Posts
    562
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    199054

    Unhappy Emu 1820m Dock Repair..?

    Sign in to disable this ad
    Hello..It's been a long, long time posting..Had some medical problems, better now..! Anyway, I have the 1820m and for some reason it stop recording thru the line inputs on the back of the Dock but records thru the two mic/line inputs on the front..!..Anyone here familiar with the repairs of the 1820m? I know it's famous for the two caps going bad and I have had those replace about 9 years ago, so I guess it's started up again as I have some static issues also. I know, get another card. But I like this one and I've heard some of the new ones and unless you get up there in price nothing blows my 1820m out of the water..Anyone can change out the caps and see if this is causing the non recording issues..? I'll pay. Thanks..!

  2. #2
    Join Date
    Jun 2012
    Location
    WALES, UK
    Age
    68
    Posts
    487
    Thanks
    4
    Thanked 27 Times in 26 Posts
    Rep Power
    5254892
    Sorry to hear you're having problems, but a little more detail might help?

    Where are you in the world?

    Have you got do you know the value/type of caps that are needed?

    I'm in the UK & pretty handy with a soldering iron but if you're in the US, the shipping would be a lot?.

    I love fixing things & helping people, but if the value etc of the caps can't be seen it would be very difficult to find out what they should be thanks to Creative discontinuing EMU?

    Hope you find a solution?.

    Ps, I have a 1616m so I know how people fall in love with EMU?
    I started out with nothing, & I've still got most of it left seasick steve

  3. #3
    Join Date
    Aug 2005
    Location
    U.K.
    Age
    33
    Posts
    19,390
    Thanks
    1,198
    Thanked 1,014 Times in 895 Posts
    Rep Power
    1000000
    +1.Would you be confident enough to open the unit for inspection?
    Quite often capacitors will leak or bulge to let you know there's a problem.

    Not always....but often.
    ---------- Steenaudio Website ----------

  4. #4
    Join Date
    Jun 2012
    Location
    WALES, UK
    Age
    68
    Posts
    487
    Thanks
    4
    Thanked 27 Times in 26 Posts
    Rep Power
    5254892
    Quote Originally Posted by Steenamaroo View Post
    +1.Would you be confident enough to open the unit for inspection?
    Quite often capacitors will leak or bulge to let you know there's a problem.

    Not always....but often.

    And if you do, Maybe a couple of pics?.
    I started out with nothing, & I've still got most of it left seasick steve

  5. The Following User Says Thank You to jiff 41 For This Useful Post:


  6. #5
    Join Date
    Jul 2005
    Posts
    562
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    199054
    Hey fellas. sorry about the delay to this question. Thanks for your input. I'm in USA..I opened the unit and I don't see any bulging caps..Funny, as I stated the two front inputs on the Dock was working but now just one is working..!..I tried other Cat-5 cables and still not working. Do you think this could be a driver issue..?..May be try re-installing drivers ?..As I stated , I can see signal into Patch mix but it's not making it back into Reaper..Funny that any input would be working at all, if it was software issue tho...Thanks..!

  7. #6
    Join Date
    Jun 2012
    Location
    WALES, UK
    Age
    68
    Posts
    487
    Thanks
    4
    Thanked 27 Times in 26 Posts
    Rep Power
    5254892
    No pics?

    About a year ago I bought an LR Baggs venue unit from Ebay (Second hand) & after a couple of gigs I noticed it was cutting out?,
    So I opened it up couldn't see anything untoward @ first but I started just gently touching the components on top while looking underneath, & straight away I could see a bad solder joint (not dry, just loose!), So out came the soldering iron & a couple minutes later & the problem was solved & it's been working great ever since!, So sometimes it's not obvious @ first glance?.
    I started out with nothing, & I've still got most of it left seasick steve

  8. #7
    Join Date
    Jul 2005
    Posts
    562
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    199054
    Quote Originally Posted by jiff 41 View Post
    No pics?

    About a year ago I bought an LR Baggs venue unit from Ebay (Second hand) & after a couple of gigs I noticed it was cutting out?,
    So I opened it up couldn't see anything untoward @ first but I started just gently touching the components on top while looking underneath, & straight away I could see a bad solder joint (not dry, just loose!), So out came the soldering iron & a couple minutes later & the problem was solved & it's been working great ever since!, So sometimes it's not obvious @ first glance?.
    Hello..Sorry bout no pics..I'm trying to learn how on this phone of mine..Ok, ok si I'm a dinosaur....I'll try to get a pic tho..I did at one time wiggle the EDI cable near the Dock input and I could have sworn I saw signal flash on an armed track.! Could be wishful thinking tho..Do those connectors (female RJ-45 (?) go bad often..?

  9. #8
    Join Date
    Feb 2009
    Location
    northampton uk home of Dr Who and Blackstar Amps!
    Posts
    9,914
    Thanks
    1
    Thanked 660 Times in 624 Posts
    Rep Power
    9269082
    Quote Originally Posted by snatchman View Post
    Hello..Sorry bout no pics..I'm trying to learn how on this phone of mine..Ok, ok si I'm a dinosaur....I'll try to get a pic tho..I did at one time wiggle the EDI cable near the Dock input and I could have sworn I saw signal flash on an armed track.! Could be wishful thinking tho..Do those connectors (female RJ-45 (?) go bad often..?
    RJ45s are among THE most reliable connectors, can survive my size 12s! But you can get crap in the jacks. Look in with a light and a glass and check the contacts are clean, straight and that there is no debris in there.

    After that there could be a dry joint on the jack pins on the PCB but be careful soldering same, easy to 'blob across'.

    If those caps were replaced with anything REMOTELY decent they won't have failed in nine years. Thirty maybe!

    Dave.

  10. #9
    Join Date
    Aug 2005
    Location
    U.K.
    Age
    33
    Posts
    19,390
    Thanks
    1,198
    Thanked 1,014 Times in 895 Posts
    Rep Power
    1000000
    Quote Originally Posted by snatchman View Post
    I can see signal into Patch mix but it's not making it back into Reaper.
    For all inputs? If so, this is a software setup issue.
    ---------- Steenaudio Website ----------

  11. #10
    Join Date
    Jul 2005
    Posts
    562
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    199054
    Quote Originally Posted by Steenamaroo View Post
    For all inputs? If so, this is a software setup issue.
    Hello..All back inputs on the Dock not working.( Well, the inputs are actually working because I can see signal on Patch Mix. it's just not coming back out of feed into the computer).. One input on the front is working fine..I tried another cat-5 cable ( not the original style, yet some say regular cat-5 works) but it still didn't work. Maybe it's the female connector in the Dock that's bad..?...I was thinking software issue but I don't know now. Do you think reinstalling the Emu's driver may help.? Anyone ever have similar problems that reinstalling drivers helped.? Thanks..!
    PS..I know plenty may say, just get another interface. At the moment can't....Plus, if it's something simple like drivers or caps, I rather just keep it. It's not like I'd be getting a big nite and day difference in audio quality from what I'm hearing of the new interfaces.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DIY IPOD dock.
    By Steenamaroo in forum DIY, Mods, and Homebrew
    Replies: 19
    Last Post: 05-29-2013, 15:16
  2. I/O Dock, QX-25 and Garage Band
    By JMAR in forum Newbies
    Replies: 1
    Last Post: 08-28-2012, 04:43
  3. Yamaha MD8 repair will be expensive - repair or replace?
    By stodge in forum Gear Reviews & Questions
    Replies: 9
    Last Post: 05-07-2007, 18:01
  4. *Help* My Emu 1820M Audio Dock is not turning on.
    By Phoenix5891 in forum Digital Recording & Computers
    Replies: 4
    Last Post: 01-06-2005, 07:00
  5. firewire dock
    By bugsy34 in forum Alesis Forum
    Replies: 4
    Last Post: 09-05-2002, 17:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •