Results 1 to 2 of 2

Thread: Teac 80 pop issue

  1. #1
    Join Date
    Apr 2012
    Posts
    122
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    5332

    Teac 80 pop issue

    Sign in to disable this ad
    I have noticed over the past few uses that my Teac pops really loudly when I stop, RW/FW. It pops loudly in my speakers and when I arm/disarm the tracks for recording. Anyone come across this issue before?

  2. #2
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124
    can't say I have but it sounds like a blocking cap is bad somewhere...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Teac 80-8 Motor Issue
    By thereelman77 in forum Analog Recording & Mixing - Tape & Gear
    Replies: 5
    Last Post: 01-30-2013, 21:29
  2. Teac 80 8 Channel Card Recording Issue
    By thereelman77 in forum Analog Recording & Mixing - Tape & Gear
    Replies: 3
    Last Post: 05-21-2012, 22:36
  3. TEAC 144 output issue
    By adamvelvetu in forum Analog Recording & Mixing - Tape & Gear
    Replies: 5
    Last Post: 04-10-2010, 10:12
  4. Internal grounding issue with Teac A-3340S
    By ofajen in forum Analog Recording & Mixing - Tape & Gear
    Replies: 14
    Last Post: 10-02-2009, 13:41
  5. Teac 4010-S preamp issue
    By Muckelroy in forum Analog Recording & Mixing - Tape & Gear
    Replies: 6
    Last Post: 03-05-2005, 01:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •