Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19

Thread: Tascam TSR8 pinch roller rubber turns to gunk, replacement advice.

  1. #11
    Join Date
    Jan 2015
    Location
    paradise
    Posts
    3,980
    Thanks
    99
    Thanked 473 Times in 428 Posts
    Rep Power
    7525742
    Sign in to disable this ad
    Yup that rubber conditioner is pure crap. Used it once years ago wnd it turned a perfectly roller to a gummy mess.
    Mild dish soap for cleaning has always worked for me.

  2. #12
    Join Date
    Mar 2004
    Location
    London
    Posts
    367
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    5497
    Terrys re-furbished pinch roller has arrived back & is now working on my TSR-8!

    One minor problem on my machine, is that my channel 4 signal disappears when DBX is switched on, maybe a problem with the channel card which I'll have to check when time allows!

    Or has anyone got any idea of what causes this weird problem as all other channels work fine, DBX on or off!

  3. #13
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,257
    Thanks
    174
    Thanked 185 Times in 168 Posts
    Rep Power
    3657311
    I would:

    1. Re-seat amp cards and dbx cards (if applicable) and if that doesn't resolve the issue...
    2. Swap an amp card and see if the problem follows the card, and if the machine has separate dbx cards do a swap with those to see if the problem follows the card.

    I love a fresh roller from Terry!

  4. #14
    Join Date
    Nov 2004
    Location
    Wales
    Age
    42
    Posts
    3,317
    Thanks
    10
    Thanked 81 Times in 75 Posts
    Rep Power
    2178546
    I think the DBX is integrated. If reseating doesn't help, and the problem definitely moves with the card, I can probably spare one from my parts machine.

  5. #15
    Join Date
    Mar 2004
    Location
    London
    Posts
    367
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    5497
    Thanks Guys! I seem to remember a few years it being the same problem & channel before, it started working fine after I left the machine on a few hours. Could be until Xmas before I get a real chance to look inside.

  6. #16
    Join Date
    Jan 2006
    Location
    Fremantle, Australia
    Age
    61
    Posts
    5,576
    Thanks
    0
    Thanked 175 Times in 158 Posts
    Rep Power
    11371253
    I think it's a different card to the record/playback card, maybe mounted from the other side of the machine? I may be talking rubbish as it's 20 years since I owned one.

    However sometimes just moving the cards around fixes these problems by breaking the oxide on the terminals.

    Alan.

  7. #17
    Join Date
    Nov 2004
    Location
    Wales
    Age
    42
    Posts
    3,317
    Thanks
    10
    Thanked 81 Times in 75 Posts
    Rep Power
    2178546
    Quote Originally Posted by witzendoz View Post
    I think it's a different card to the record/playback card, maybe mounted from the other side of the machine? I may be talking rubbish as it's 20 years since I owned one.
    However sometimes just moving the cards around fixes these problems by breaking the oxide on the terminals.
    Alan.
    Yeah, looking at the service manual this morning I can only see the 8 channel cards with no daughterboards. They are quite dense circuitry, and the DBX-related pots look like they're all down one end so I would assume the DBX is onboard.

  8. #18
    Join Date
    Dec 2016
    Posts
    43
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Rep Power
    0
    Glad you got the roller replaced. I recently bought one for $80 on eBay to fix my TSR8. I'm just glad they still make these.

  9. #19
    Join Date
    Mar 2004
    Location
    London
    Posts
    367
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    5497
    I swapped the channel cards around & the problem followed the card, looks like the DBX chip & encoder trimmers are by top side left (component side). I've re soldered the relay connections just in case, part link below.

    https://uk.farnell.com/omron-electro...-2a/dp/9949178

    Another relay, I'm not sure if this one is connected to the DBX area? I'll re-flow the solder connections on this one.

    SY-12W-K Fujitsu | Mouser United Kingdom


    The 3pin molex from the relay to the dbx section is fine. It would help If I could find my service manual!

    EDIT: DBX calibration, looks like I also need a function generator, AF oscillator & an attenuator, got everything else, it appears that the cards are calibrated outside the machine. I really need to get this channel card working as I calibrated the levels before I sold my alignment tape.

    Anyone know any good service technicians? Near London / South East England?
    Last edited by trancedental; 1 Week Ago at 07:49.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pinch (rubber roller) roller for Tascam 38
    By TASCAM MAN in forum TASCAM User Forum
    Replies: 25
    Last Post: 08-17-2015, 18:02
  2. Tascam 38 Pinch Roller in the UK?
    By jamievespa in forum Analog Recording & Mixing - Tape & Gear
    Replies: 9
    Last Post: 07-15-2012, 13:19
  3. Pinch Roller Rubber cleaner??
    By yetipur in forum Analog Recording & Mixing - Tape & Gear
    Replies: 6
    Last Post: 06-23-2008, 10:32
  4. Tascam 48 Pinch Roller
    By Ladnar in forum Analog Recording & Mixing - Tape & Gear
    Replies: 36
    Last Post: 01-08-2008, 08:00
  5. Got my Tascam 48/pinch roller advice
    By EDAN in forum Analog Recording & Mixing - Tape & Gear
    Replies: 6
    Last Post: 11-01-2006, 05:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •