Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Tascam M308 problem

  1. #1
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Tascam M308 problem

    Sign in to disable this ad
    I would just like to firstly say that I have very little knowledge of analog equipment and just picked up this mixer b/c I read that it was great sounding and it was very affordable. I got an M308 off of craigslist for a really good price. When I picked it up it looked to be in good condition and I tested it out there; every channel worked and the only problems that I could find were one pan knob was broken off and one fader was missing. Now that I took it home it suddenly stopped working. It powers up but I can't get it to work. I plugged in a mic and a bass and got no signal on every channel. Does anyone know what could be wrong? I was thinking of buying the manual from tascam but if its dead then I don't want to waste $40 and I was considering bringing it in to a repair shop. I only paid $80 so if its cheep to repair I would be willing to bring it into a shop. If anyone has any suggestions I would appreciate your advice.

  2. #2
    Join Date
    Aug 2005
    Location
    Shillington, PA
    Age
    57
    Posts
    170
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    187831
    Make sure your line/mic switch is in the right position and that you have the orange l/r buttons in on the channels you are using. Also in the master section. And make sure the channels are turned on (green lights lit) Should get audio through the board.

  3. #3
    Join Date
    Apr 2006
    Location
    st lou burb
    Age
    66
    Posts
    2,704
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    1298056
    does it have the jumpers for the inserts????
    37.8% of all statistics are made up on the spot...

    hey give a guy some room... people are trying to evolve here... for crying out loud...

  4. #4
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Those three buttons are in the right positions and the green light is lighting up. Demented I'm sorry but what do you mean by the jumpers for the inserts?

  5. #5
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124
    He's talking about the SEND RCV jacks on the back...should be a thingy bridging/linking the two on each channel...without it nothing gets through...

  6. #6
    Join Date
    Aug 2005
    Location
    Shillington, PA
    Age
    57
    Posts
    170
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    187831
    I have an M320, doesn't need any jumpers. 1/4 inch jacks for the inserts. Pretty sure the 308 is the same.

  7. #7
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124

    Exclamation

    Daveg62...my bad. I wondered about that...just looked at some pictures. You are absolutely correct about the whole 300 line. No separate SEND RCV jacks on RCA's on the 300-series...1/4" unbalanced TRS jacks.

    • Hm...adavidowitz...dunno...
    • Are you able to get the "OL" clip LED to light on the track you are using?
    • Have you tried all channels?
    • Any rough-handling incidents on the way home?
    • How/where was the mixer placed in the transport vehicle?

  8. #8
    Join Date
    Sep 2008
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for the help guys.
    I can't get the clip light on, I tried all channels and it sat flat in my trunk for the twenty minute ride home. I don't think it got banged around much during transport. Any idea whats wrong?

  9. #9
    Join Date
    Apr 2006
    Location
    st lou burb
    Age
    66
    Posts
    2,704
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    1298056
    my bad on the inserts... seems like tascam always liked doing it this way ...

    let's see... how about something chosen in the master section that mutes the rest???
    37.8% of all statistics are made up on the spot...

    hey give a guy some room... people are trying to evolve here... for crying out loud...

  10. #10
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124
    I'd like to help, but somebody is going to have to lead me to a hi-res pic of the top panel of a 300-series mixer...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Using my Digi 002rack w/ Tascam TRS-8 and M308 Mixer
    By Rickson Gracie in forum Analog Recording & Mixing - Tape & Gear
    Replies: 8
    Last Post: 06-19-2008, 09:05
  2. Tascam M308 or M312 Monitor Hook-up question
    By Ginazgifs in forum Analog Recording & Mixing - Tape & Gear
    Replies: 9
    Last Post: 12-23-2006, 19:24
  3. M308, Who needs the manual anyway! (I do!)
    By EDAN in forum Analog Recording & Mixing - Tape & Gear
    Replies: 4
    Last Post: 09-29-2005, 18:38
  4. TASCAM M308 dimensions
    By EDAN in forum Analog Recording & Mixing - Tape & Gear
    Replies: 2
    Last Post: 09-08-2005, 13:51
  5. Connect M308 to 22-4?
    By DESSERT DWELLER in forum Analog Recording & Mixing - Tape & Gear
    Replies: 1
    Last Post: 03-02-2005, 20:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •