Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Tascam 388 needs repair?

  1. #1
    Join Date
    Oct 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Tascam 388 needs repair?

    Sign in to disable this ad
    Hi Guys....first post here

    I bought a Tascam 388 today knowing there was a fault. The right hand side/spool struggles to play but if you push the HOLD button it runs fine. So I think the motor could be okay....but something else is up.

    I'm a complete novice on this so any ideas would be cool

    Also is there anywhere in the UK I can get this fixed/seviced/set up. I'm in suffolk if that makes any difference.

    Cheers

    Joe

  2. #2
    Join Date
    Dec 2009
    Location
    Berlin
    Posts
    120
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    37447
    Quote Originally Posted by shadwell157 View Post
    but if you push the HOLD button it runs fine.
    say Joe, I can't find the "HOLD" button on my 388. Is that British English for "Tape Lifter" or "Stop"?

    But seriously, what button exactly are you pressing to make it run? You're sure that's a 388? you could post a photo to set our minds at ease...
    "Do not fear to be eccentric in opinion, for every opinion now accepted was once eccentric. " - Bertrand Russell

  3. #3
    Join Date
    Nov 2010
    Location
    NY
    Posts
    23
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    looking at my 388 notes from the old days, it would seem the most likely culprit given the limited clues would be the transport pcb. the TEAC repair facility in New Jersey would simply replace the pcb. you may be able to source the part from them. it is a transport 'logic' issue most likely, rather than mechanical, since the motor spins fine when an otherwise-dormant surface control is toggled.

    great machines, too bad they didnt make them in a 12 or 24 channel version. linking a 300 series mixer side by side just isnt the same...

  4. #4
    Join Date
    Oct 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by LUNE View Post
    say Joe, I can't find the "HOLD" button on my 388. Is that British English for "Tape Lifter" or "Stop"?
    Just me being a nonce.
    LOAD! not HOLD!

  5. #5
    Join Date
    Dec 2009
    Location
    Berlin
    Posts
    120
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    37447
    I would also check the tape tension / reel servo adjustment - you can find calibration procedures on the maintenance section of the manual (looks like page "1-9" in my manual.) I could imagine if the tension was too low maybe it would have trouble moving - don't know why it would be different with 'Load' engaged though. you can only do partial calibration without a tentelometer, but maybe what you can do would help. so its working fine with the "load" engaged?
    "Do not fear to be eccentric in opinion, for every opinion now accepted was once eccentric. " - Bertrand Russell

  6. #6
    Join Date
    Oct 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    still troubles

    I've been able to make adjustments so FF and RR work. But I still can't tweak it enough for Play to work

  7. #7
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124
    With tape unloaded, have a helper or otherwise find a way to raise BOTH tension arms all the way up to their stops, hold them there and then press PLAY. Are both reel tables able to spin nice and free?

  8. #8
    Join Date
    Oct 2010
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by sweetbeats View Post
    With tape unloaded, have a helper or otherwise find a way to raise BOTH tension arms all the way up to their stops, hold them there and then press PLAY. Are both reel tables able to spin nice and free?
    Hey

    If you mean pushed all the way to the top then no. They cut off spinning just about half way up.

    Hmmmmm what are you thinking?

    Cheers

  9. #9
    Join Date
    Apr 2010
    Location
    San Ramon, CA
    Posts
    509
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    238756
    Quote Originally Posted by shadwell157 View Post
    ---Hmmmmm what are you thinking?---
    He's thinking that if he can give you a bum steer you will sell him your 388 for 50 bucks!!!

  10. #10
    Join Date
    Apr 2008
    Location
    Pacific Northwest, USA
    Posts
    8,553
    Thanks
    223
    Thanked 218 Times in 198 Posts
    Rep Power
    3753124
    Oh Greg stop it...

    shadwell what I'm trying to determine is if the brakes aren't releasing. In PLAY mode the brakes should release fully so that the reel tables can spin free, and in order to test this if you raise the tension arms all the way up and press PLAY then you should be able to manually spin the reel tables and they should be drag-free. That's why it helps to have a helper...one to hold the tension arms all the way up and the other can press PLAY and check the tables. You can also use a gihugic rubber band to hold the tension arms up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tascam 388 repair ?'s
    By cracklin' in forum Analog Recording & Mixing - Tape & Gear
    Replies: 6
    Last Post: 09-14-2008, 10:27
  2. 388 repair question.
    By thegunshyboy in forum TASCAM User Forum
    Replies: 10
    Last Post: 10-10-2006, 08:59
  3. 388 repair!
    By svenagain in forum Analog Recording & Mixing - Tape & Gear
    Replies: 2
    Last Post: 10-18-2005, 13:23
  4. 388 repair!
    By svenagain in forum TASCAM User Forum
    Replies: 1
    Last Post: 10-17-2005, 22:25
  5. I have a ... get ready for this ... 388, needs repair
    By crustacean in forum TASCAM User Forum
    Replies: 4
    Last Post: 05-01-2001, 22:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •