Results 1 to 2 of 2

Thread: 388 won't play

  1. #1
    Join Date
    Oct 2008
    Location
    Irving, TX
    Age
    43
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    388 won't play

    Sign in to disable this ad
    So I have recently inherited a Tascam 388 from a frined who didn't want to move it across country. Everything appears to be working on it, except when I go to play it. If I hit record, it will turn, if I rewind, fast forward and thing except play.

    Anyone have any ideas?

  2. #2
    Join Date
    Dec 2000
    Location
    BC, Canada
    Posts
    7,098
    Thanks
    3
    Thanked 1 Time in 1 Post
    Rep Power
    1195184
    Open the bottom cover and check the capstan belt.

    EDIT: Just caught the part that you say that it works in REC but not in PLAY? When you lift up the right tension arm, does the capstan shaft spin? If not, do you hear the motor underneath engage? If yes then it's the capstan belt and it needs to be replaced.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what do you play
    By L'espion Noir in forum DJ & Hip Hop Production
    Replies: 10
    Last Post: 08-29-2007, 10:27
  2. air play anyone?
    By gullyjewelz in forum DJ & Hip Hop Production
    Replies: 3
    Last Post: 09-30-2004, 11:27
  3. Playback/play will only play in left speaker
    By liquidmusic in forum Recording Techniques
    Replies: 1
    Last Post: 11-26-1999, 21:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •