Results 1 to 8 of 8

Thread: MIDI interface problem

  1. #1
    Join Date
    Oct 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    MIDI interface problem

    Sign in to disable this ad
    I have two MIDI interfaces. One is a focusrite 2i4, and the other is a Victsing MIDI in/out cable.

    I'm using a sequencer to drive many MIDI devices, one being a PC that is using Show Control Systems using midi program changes to control lighting changes and videos.

    when I plug the MIDI in on the Victsing interface into the sequencer directly, the PC gets MIDI information like it should.
    As soon as I plug this into a Thru outlet on another of my devices, it won't receive data.

    So to narrow down the problem, this Victsing MIDI/USB interface won't receive any data from a THRU port where I know data is present.

    The focusrite interface will receive data just fine from the thru port of any device.

    Is there something special about these interfaces that will cause them to fail reading thru data (which I always just assumed was a rebroadcast of whatever came in from the "IN" port.?

    Thanks in advance for any help you can give.

  2. #2
    Join Date
    Nov 2017
    Posts
    53
    Thanks
    11
    Thanked 4 Times in 4 Posts
    Rep Power
    93652
    How strange! There's really nothing special about Midi thru data. It's pretty much a copy of what comes into the midi-In port. I don't see how this interface can tell the difference between data coming from the Midi Out or Midi Thru of another device.

    So if you connect the Midi-Out of the same source to the Midi-in port of this Victsing card, everything works fine?

  3. #3
    Join Date
    Sep 2012
    Posts
    6,506
    Thanks
    257
    Thanked 437 Times in 406 Posts
    Rep Power
    12973598
    MIDI through to MIDI in? Also, double check to make sure it is receiving the broadcasts, MIDI All should be set or a specific channel. 1-1, 2-2 etc.
    DM60 Tunes: The Collection

  4. #4
    Join Date
    Oct 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by SAM CA View Post
    How strange! There's really nothing special about Midi thru data. It's pretty much a copy of what comes into the midi-In port. I don't see how this interface can tell the difference between data coming from the Midi Out or Midi Thru of another device.

    So if you connect the Midi-Out of the same source to the Midi-in port of this Victsing card, everything works fine?
    Yes. That is what is so weird. If I plug this Victsing MIDI/USB out directly into the MIDI out of my sequencer, the Victsing receives DATA as it should.
    If I connect the sequencer out to any other device, and plug the Victsing into the thru port of that device, it registers nothing.

    I have a MIDI Solutions thru box, which is just a one in, two thru splitter. Even adding just that to the chain between the sequencer and the victsing will cause the victsing to no longer receive MIDI data, but the thru box will supply every other piece of gear on the chain as normal.

    I really don't want to haul this focusrite interface around with me for live shows. The simple USB/MIDI cable would be so much easier....if it worked.

    Thanks for the message.

  5. #5
    Join Date
    Oct 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by DM60 View Post
    MIDI through to MIDI in? Also, double check to make sure it is receiving the broadcasts, MIDI All should be set or a specific channel. 1-1, 2-2 etc.
    Yes. This interface doesn't receive any data on any channel when plugged into a MIDI thru, but works fine when plugged into a MIDI out.

    In this setup, I have 5 midi devices. all of them receive data as they should with the exception of this Victsing interface. It only works when I plug it directly into a MIDI out. (The sequencer, a keyboard, etc.)

    Amazon.com: VicTsing USB IN-OUT MIDI Cable Converter PC to Music Keyboard Adapter Cord: Musical Instruments

  6. #6
    Join Date
    Sep 2012
    Posts
    6,506
    Thanks
    257
    Thanked 437 Times in 406 Posts
    Rep Power
    12973598
    Quote Originally Posted by tamoore View Post
    Yes. This interface doesn't receive any data on any channel when plugged into a MIDI thru, but works fine when plugged into a MIDI out.

    In this setup, I have 5 midi devices. all of them receive data as they should with the exception of this Victsing interface. It only works when I plug it directly into a MIDI out. (The sequencer, a keyboard, etc.)

    Amazon.com: VicTsing USB IN-OUT MIDI Cable Converter PC to Music Keyboard Adapter Cord: Musical Instruments
    I suggest just chaining them, In/Out/In/Out and then set the channels. I have never used MIDI through but really, if you just chain all of your devices and set the channels, (like a loop, it should work just fine. That is assuming the old MIDI DIN plugs.
    DM60 Tunes: The Collection

  7. #7
    Join Date
    Oct 2006
    Posts
    14
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by DM60 View Post
    I suggest just chaining them, In/Out/In/Out and then set the channels. I have never used MIDI through but really, if you just chain all of your devices and set the channels, (like a loop, it should work just fine. That is assuming the old MIDI DIN plugs.
    MIDI out only sends data originating from that specific device. Since I'm sending MIDI data from one source through 5 devices on 5 different channels, I need all of the data to be present at all devices. I need to use Thru to chain. Anyway, I appreciate the replies. I'm just cutting my losses on this cable and getting an IK iRig MIDI2 interface. That should cure my problem.

    Thanks again.

  8. #8
    Join Date
    Sep 2012
    Posts
    6,506
    Thanks
    257
    Thanked 437 Times in 406 Posts
    Rep Power
    12973598

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MIDI IN - interface or keyboard problem
    By lukasz.jan95 in forum Newbies
    Replies: 3
    Last Post: 02-16-2016, 02:36
  2. MIDI Drum Trigger/Module/Interface Problem
    By cthulhu in forum MIDI Mania
    Replies: 1
    Last Post: 07-18-2010, 06:07
  3. Replies: 0
    Last Post: 05-29-2009, 23:56
  4. Fw-1082 audio/midi interface firewire problem
    By 10538 in forum TASCAM User Forum
    Replies: 1
    Last Post: 08-03-2007, 11:37
  5. MIDI interface and USB problem IMPORTANT!!!!
    By pisces7378 in forum MIDI Mania
    Replies: 0
    Last Post: 01-23-2001, 09:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •