Quote Originally Posted by 4greatKeyboards View Post
I mentioned a fix for the regulation problem. Actually there are two. In my own case I found two or three of the support brackets (with black screw in pix) have one mounting screw that is stripped out. It's the one that is within the area of the moving key weight-arms.

Ok, that's the first thing to fix. I'll be looking for some liquid product to squirt into the stripped out thread holes. I assume there are some.

The second thing is to use software to balance out all the velocities. More later.

If you aren't familiar with regulation- it's a process used on acoustic pianos to get each note to sound with the same loudness for the same note striking force. Like if you were to play a chromatic run from one end of the keyboard to the other. You want each successive note to sound with the same volume- given that you are pressing each with the same force (or weight as in weight-technique). Regulation has to be done for each individual instrument. All pianos, and some synths like Fatar, need regulation no matter how fine they are.

Cheers!
I know this is an old thread but I'm kind of desperate here. If you have already blazed this trail, maybe I can learn from your experience. I love the key bed, but i'm having the same issues you had. You mentioned that you intended to use software to balance out all the velocities. What did you mean? How is this accomplished and what software do you use? If you originally replaced the rubber note triggers because of the velocity inconsistency, why couldn't you just use the same software to regulate the velocities instead of taking this thing apart?